Cyber Warfare

Known Exploited Vulnerabilities (KEV) Catalog By CISA

CISA has urged organizations and all federal agencies to strictly follow the Known Exploited Vulnerabilities catalog as a step against ransomware attacks.  

by Vishwa Pandagle October 13, 2023 in Cyber Warfare, Firewall Daily Reading Time: 3 mins read 0

605 SHARES 3.4k VIEWS Share on LinkedInShare on Twitter

The Cybersecurity and Infrastructure Security Agency (CISA) of the United States has taken yet another step to make vulnerability management easier. Along with the ongoing efforts around the Cybersecurity Awareness Month campaigns all throughout October, CISA has been regularly updating all the Known Exploited Vulnerabilities (KEV) in a catalog.

This Known Exploited Vulnerabilities catalog by CISA is meant to prevent vulnerability exploitation that makes and has made ransomware attacks and data encryption possible for threat actors. The KEV catalog outlines steps to mitigate risks faster and create clarity about vulnerabilities that may be lingering in legacy devices.

Known Exploited Vulnerabilities Catalog to Stop Ransomware

(Photo: Cybersecurity and Infrastructure Agency)

Addressing the concern of known common vulnerabilities and exposures (CVE), CISA stated, “….many organizations may be unaware that a vulnerability used by ransomware threat actors is present on their network.”

“To help organizations overcome this potential blind spot, the Cybersecurity and Infrastructure Security Agency (CISA) established the () in January 2023, as required by the Cyber Incident Reporting for Critical Infrastructure Act (CIRCIA) of 2022,” the CISA report added.

CISA noted that with the comprehensive Known Exploited Vulnerabilities catalog teamed with the Ransomware Vulnerability Warning Pilot organizations will have all the resources they need to instantly find and install updates. The following details can be found in KEV by CISA –

  1. Vulnerabilities along with all the related details about it like vendor, product, data reported etc.
  2. Status of exploitation in ransomware campaigns
  3. Patch and update details
  4. Go to links from vendors

Known exploited vulnerabilities have caused severe damage to not just classified government data, but all organizations across the globe. CISA urged all federal civilian executive branch (FCEB) agencies to strictly adhere to the guidelines in the KEV catalog by CISA.

The CISA report added, “All federal civilian executive branch (FCEB) agencies are required to remediate vulnerabilities in the KEV catalog within prescribed timeframes under Binding Operational Directive (BOD) 22-01.”

It also urged all stakeholders to include a requirement to peruse the KEV by CISA as part of their own vulnerability management plan for collective resilience.

Threat actors have been vehemently accusing governments and nations of supporting nations that they do not support. Following this, they have been leaving threats and launching attacks leading to data loss, lawsuits, and chaos among the guardians of cybersecurity.

Hence, users must check all the relevant links placed in the KEV catalog and follow the remediation steps offered.

Source

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button